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CEO’s Message 

Dear readers, 

 

Under the 1st Construction Productivity Roadmap introduced in 2010,  

BCA had introduced Building Information Modelling (BIM) as a key enabler   

of productivity in Singapore’s construction industry. Today in 2015, more   

than 60% of the larger contractors and 80% of the larger consultants 

have adopted BIM. Moving forward, we have drawn up the 2nd  

Construction Productivity Roadmap where we would like to 

advance beyond BIM adoption by individual firms, and leverage  

on BIM technology for greater integration and collaboration  

among all firms across the value chain. 

 

Together with the industry, we will continue to explore the unchartered areas of BIM software 

integration, machine automation and process re-engineering to achieve a quantum leap in the 

adoption of BIM technology and methodologies that are aligned with our local practices.  

 

We would like to encourage the industry to continue our partnership in improving and 

expanding the BIM Essential Guides Series, to plug the gaps as more stakeholders play a part 

in the input and sharing of information and benefits generated from BIM. 

 

We would like to thank the valuable time and efforts of the BIM Managers Forum and the 

leadership of the BIM Steering Committee, chaired by Er Lee Chuan Seng, Emeritus Chairman, 

Beca Carter, that enabled the release of this document. 

 

 

Dr John Keung 
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OBJECTIVES 

Building information Modelling (BIM) is fast becoming a standard tool for building design and 

construction in Singapore. BIM can also be used for various forms of analyses, especially 

Building Performance Analysis (BPA). With BIM, more accurate and efficient analysis processes 

can be expected.  

In order to achieve sustainable design goals through BIM-based BPA, it is necessary to transfer 

essential information, such as accurate model geometry, into different file formats and BPA 

software.  

The objective of this Essential Guide is to demonstrate the transfer of this essential 

information between commonly used software and formats, i.e. from BIM Authoring tools into 

Trace 700, IES-VE, Carrier E20-II, Design Builder and Ecotect software, through the gbXML 

format.  A step by step guide of the transfer of a specific BIM authoring tool can be found in 

the gbXML File Export Process chapter.   

Example of transfer from BIM to BPA software 

 

This is not an extensive document that covers all scenarios that might arise based on specific 

projects. Users are allowed to edit/change accordingly to suit their needs.  
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Common Exchange Formats  

 
green building XML (gbXML) FORMAT  
 

The green building XML format was developed to facilitate the transfer of information from 

the BIM model into BPA tools. The gbXML schema organizes information according to the 

following hierarchy: Location, Building, Space, Surface and Opening. It is usually used for BPA 

requiring enclosed volumes, such as analysis for views, daylight, thermal and acoustics.  

gbXML Structure 
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Preparing the Analytical Model  

 

It is crucial to create an analytical model from a BIM model. The analytical model will consist 

of spaces found in the BIM model. One can make changes to the analytical model without 

modifying the BIM model. Other points to note include: 

 Only significant spaces, corresponding to thermal zones, should be defined as space 

elements.  

 Smaller space elements, such as shafts, storage spaces and mechanical spaces of 

minimal impact, should be grouped together.  

 All space elements must be fully bounded with correct heights and dimensions, and 

each of their location and other properties must be specified in the analytical model.  

 Openings such as windows and skylights should be defined in the analytical model, 

but their properties (thickness, U value, transmittance coefficient and solar heat gain 

coefficient) can be defined after data transfer within the BPA software.  

 Analytical surfaces for floors, walls, and roofs must be bounded and connected to 

other elements where necessary.  

 Shading surfaces that are treated as analytical surfaces of walls, floors or roofs not 

bounding a room can be exported as simple surfaces. 

 

 

Example of an analytical model (left) generated from a BIM model (right) 

  
 

 

http://www.aecbytes.com/buildingthefuture/2010/RevitServer_CEA.html
http://www.aecbytes.com/buildingthefuture/2010/RevitServer_CEA.html
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gbXML File Export Process  

 

After all spaces have been defined in the BIM model, the geometry and space data can be 

exported via gbXML format and imported into the BPA software. This section describes the 

gbXML export process for Trace 700, IES-VE, Carrier E20-II, Design Builder and Ecotect 

software. 

 

For TRane Air Conditioning Economics (TRACE) 700 
 

Step 1: Export gbXML file from BIM authoring tool 

 

 After the BIM Model has been checked, go to File → Export → gbXML 

 Set the location and the ground plane in the dialog box  

 The remaining parameters can be left on the defaults, as the default parameters will 

be overridden in the TRACE model.  

 After checking project parameters, click next, and save the gbXML file in your project 

folder. 

 

Step 2:  Import gbXML file into TRACE   

Before importing, check the gbXML geometry using the gbXML2dwfx.exe utility and Autodesk 

Design Review, a 2D and 3D DWF viewer.  

 Drag and drop the gbXML file to gbXML2dwfx.exe to generate a DWFx file, which can 

be viewed in Autodesk Design Review. 
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 Check the geometry visually to identify any 

major issues (gaps in the model, missing 

spaces, surface recognition etc).  

 When the gbXML file is checked and ready to 

be imported, open a new TRACE Program, and 

select file → import gbXML. Use the dialog to 

select which gbXML parameters should be 

imported. Only select the parameters that 

you have defined in the BIM authoring 

software.  

 Once imported into TRACE, the model should 

be thoroughly checked again. 

 

 

 

Step 3: Manual Inputs & Checking  

After importing the gbXML file, check that the data was correctly imported into TRACE. In 

particular, check the following:  Rooms, Roofs, Walls, Internal Loads, Airflows and Partitions / 

Floors, and make adjustments in the BIM authoring software or the TRACE file as required.  
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Minor geometry changes can be made manually in TRACE  

 

Step 4: Re-importing gbXML process  

The spaces inside the BIM authoring tools should be updated so that the zoning diagram 

reflects the changes. Major geometry updates will require adjusting the spaces directly in the 

BIM model and re-importing the gbXML file into TRACE.   

 

For IES Virtual Environment (IESVE) 
 

Step 1: Set export settings to export gbXML file from the BIM authoring tool 

 After the model has been checked, go to File→ Export → gbXML 

 Set the Building Type, Location and the Ground Plane as shown below 
 

 

 

 

 

 

 

 



BIM Essential Guide – For Transfer of BIM Data into Building Performance Analysis (BPA) 

 

6 

 

 For Export Complexity, choose “Simple” if no shading surface has been defined. 

Choose “Simple with Shading Surfaces” if overhangs or fins were defined in the BIM 

authoring tool (by drawing in roof surfaces earlier). To reduce the IES-VE model run 

time, try to reduce the quantity of shading surfaces and keep the geometry as simple 

as possible. Shading surfaces can also be defined later in ModelIT, which is IES’s 3D 

building geometry tool. 

 After checking project parameters, click Next, and save the gbXML file in your project 

folder 

 

Step 2: Import into IESVE 

 Open a new IESVE project. Go to 

file → import gbXML and browse 

for the gbXML file. The model 

check window will come up. 

 

 Check the geometry of the model 

in the viewer window, and select 

which surface type to import. 

The categories at the bottom of 

the window can be left as 

“default” and assigned later.  

 

 Click okay and check each level in 

IESVE. 

 

 The schedule will be imported 

into IESVE. It is recommended to 

export a .GEM geometry file from 

ModelIT, and import the 

geometry file into a new IESVE 

project file.  
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For Carrier E20-II 
 

Step 1: Project Set-up for gbXML Exporting  

 Make sure that the Architectural BIM Model is linked into the MEP BIM Model. 

 Acquire the True North orientation from Manage Tab → Coordinates → Select (the 

linked architectural model). Change the orientation of the project on the Properties 

panel if necessary.  

 
 

 Set the Area and Volume Computations values on the Analyze Tab  Space & Zones 

panel drop-down. 

 

 
 To create spaces in all areas of the model, you can place spaces manually or 

automatically through Modify  Place Space tab  Spaces Panel  Place Spaces 

Automatically.  
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 The names and numbers from the rooms in the Architectural BIM model can be 

assigned to the spaces by using example like Autodesk Revit Space Naming Utility, at 

the Add-Ins tab → Space Naming Utility → Names and Numbers. Spaces can be 

named manually if the Space Naming Utility tool is not available. (Note: the utility is a 

free app that can be downloaded and installed through an Autodesk Subscription 

account) 

 Verify the extents of all spaces based on the rooms of the Architectural BIM model. It 

is important that space extents are not overlapping, which will create inconsistencies 

in the data to be gathered. To verify the extents: 

o Create and open a section of a room 

o Verify the space placement by opening the View tab Graphics panel  

Visibility/Graphics → Spaces → tick Interior and Reference (if you want to 

display reference crosshairs) 

o Adjust Spaces if extent is not met  

o To make sure that all spaces extents are correct, go to the floor plan , go to 

Properties panel  Limit Offset  specify the height limit of the level that 

you are checking, and select all spaces within that level 

 
 After all space extents have been verified, export the model into gbXML file.  

 Go to the Application Menu and select Export → gbXML File  
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 Verify the accuracy of the gbXML file in the dialog to avoid any errors when loading 

the gbXML file into Carrier’s Hourly Analysis Program.  

 Adjust settings as shown in the figure below. Click Next when ready for export.  

 
 

Step 2: Importing the gbXML file into Carrier’s Hour Analysis Program  

 Open the Hour Analysis Program 

 Retrieve the company template for analysis  

 
 

 Go to the Project Tab and click Import gbXML  

 Locate and load the file  

 After importing, the gbXML data will be 

automatically loaded to the Carrier Analysis 

Program for verification, as shown in the 

following page. 
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 Proceed with calculations on Carrier E20-II using the data that was automatically 

generated from the model.  
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 Partition data will not be transferred together with the gbXML file during import into 

the Hourly Analysis Program. For calculation purposes, the data has to be extracted 

directly from the BIM model, as shown below, and keyed in manually to supplement 

missing information in the Hourly Analysis Program.  

 

 
 

 Key in the Area Partition Data in E20-II to get the required load calculation.  

 Data that is transferred automatically into the E20-II is shown below 

 

(i) General Information on each space (ii) Data for walls, windows and doors 
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For DesignBuilder 
 
To facilitate the direct export of BIM model data, including certain building parameters, 

directly from the BIM authoring tool into the DesignBuilder software, a DesignBuilder plug-in 

can be added into the BIM authoring tool such as the example shown below. (Note: This plugin 

is only available after DesignBuilder has been installed on the same computer as the BIM 

authoring tool) 

 

After checking the model within the BIM authoring tool, click on Add-Ins tab  Export button 

on DesignBuilder panel, and check the model again in the DesignBuilder Export dialog. 
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For Ecotect Analysis 
 

Step 1: Set export settings to export gbXML file from the BIM authoring tool (see IESVE, pg 5) 

Step 2: Importing the gbXML file into Ecotect Analysis  

 When importing the gbXML file into the Ecotect Analysis software, the following error 

message may appear 

 
 

 This error message appears because the generated gbXML file is not encoded in a 

format that is recognized in Ecotect Analysis.   

 The simplest workaround is to open the gbXML file in Windows Notepad and save the 

file separately as a new Text Document with the UTF- 8 Encoding.  
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Communicating with Project Teams  

Space placement can be performed with or without the architect’s involvement. If the 

architectural 2D data or BIM model is used as reference in the background without recognizing 

room-bounding elements, the zoning is independent of the reference.  

If the room-bounding elements of the architectural BIM model are recognized, the 

architectural BIM model should specify the following rules as much as possible: 

1) Ensure all exterior walls, floors and roof elements are room-bounding.  

2) Ensure all ceilings are not room-bounding  

3) Ensure all columns are not room-bounding  

Also, before placing spaces, communicate with the project team and BIM Coordinator 

regarding model set-up. Spaces hold information related to other disciplines, and can be used 

for other purposes beyond zoning.  

Because spaces must not overlap within the model, it is important to discuss space zoning 

with the whole team. If, for example, the electrical team wants to store electrical loads in 

spaces, it may make sense to place one space per room in the MEP model (using space 

bounding functions), and if necessary, create a separate model containing simplified zoning for 

the electrical load and energy model. 
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